Thank you for your patience and apologies for any inconvenience caused.
Service reliability is a top priority at Horizon Cloud and we are making continuous improvements to better our systems.
Please visit Service Support Website at http://my.vmware.com or call Service Support Line at 1-877-4VMWARE if you need additional assistance.
Thank You, VMware Horizon Communications Team
Posted Feb 04, 2026 - 13:23 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 26, 2026 - 12:16 UTC
Update
Horizon Cloud Service First-Gen is undergoing the weekly scheduled maintenance on the Horizon Cloud Console Access.
Maintenance Window: • Start: Wednesday, January 21, 2026, 03:30 UTC • End: Wednesday, January 21, 2026, 06:30 UTC
Impact: • There is no impact on end-users and their ability to connect to their desktops. • During this maintenance there will be a brief (not more than 2 minutes) downtime on the Administration Console. Administrative functions will be unavailable or may appear offline during this period.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Additional Information: Omnissa Horizon Cloud Service Team will provide additional updates on our Unified Status page until the maintenance activity is complete.
Posted Jan 21, 2026 - 15:09 UTC
Update
Horizon Cloud Service First-Gen is undergoing the weekly scheduled maintenance on the Horizon Cloud Console Access.
Maintenance Window: • Start: Wednesday, January 14, 2026, 03:30 UTC • End: Wednesday, January 14, 2026, 06:30 UTC
Impact: • There is no impact on end-users and their ability to connect to their desktops. • During this maintenance there will be a brief (not more than 2 minutes) downtime on the Administration Console. Administrative functions will be unavailable or may appear offline during this period.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Additional Information: Omnissa Horizon Cloud Service Team will provide additional updates on our Unified Status page until the maintenance activity is complete.
Posted Jan 21, 2026 - 12:25 UTC
Scheduled
Horizon Cloud Service First-Gen is undergoing the weekly scheduled maintenance on the Horizon Cloud Console Access.
Maintenance Window: • Start: Wednesday, January 15, 2026, 03:30 UTC • End: Wednesday, January 15, 2026, 06:30 UTC
Impact: • There is no impact on end-users and their ability to connect to their desktops. • During this maintenance there will be a brief (not more than 2 minutes) downtime on the Administration Console. Administrative functions will be unavailable or may appear offline during this period.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Additional Information: Omnissa Horizon Cloud Service Team will provide additional updates on our Unified Status page until the maintenance activity is complete.
Posted Jan 21, 2026 - 12:19 UTC
This scheduled maintenance affected: Horizon Cloud Service Next-Gen (Horizon Cloud Service Next-Gen - Ireland).