Horizon Cloud Service First-Gen is undergoing the weekly scheduled maintenance on the Horizon Cloud Console Access.
Maintenance Window: • Start: Wednesday, October 08, 2025, 03:30 UTC • End: Wednesday, October 08, 2025, 06:30 UTC
Impact: • There is no impact on end-users and their ability to connect to their desktops. • During this maintenance there will be a brief (not more than 2 minutes) downtime on the Administration Console. Administrative functions will be unavailable or may appear offline during this period.
Service reliability is a top priority at Horizon Cloud Service, and we are making continuous improvements to better our systems.
Additional Information: Omnissa Horizon Cloud Service Team will provide additional updates on our Unified Status page until the maintenance activity is complete.
Posted Dec 19, 2025 - 15:08 UTC
Update
Impact:• There is no impact on end-users and their ability to connect to their desktops. • During this maintenance there will be a brief (not more than 2 minutes) downtime on the Administration Console. Administrative functions will be unavailable or may appear offline during this period.
Posted Dec 19, 2025 - 15:07 UTC
Update
Impact: • There is no impact on end-users and their ability to connect to their desktops. • During this maintenance there will be a brief (not more than 2 minutes) downtime on the Administration Console. Administrative functions will be unavailable or may appear offline during this period.
Posted Dec 19, 2025 - 15:05 UTC
Update
Maintenance Window: • Start: Wednesday, December 17, 2025, 03:30 UTC • End: Wednesday, December 17, 2025, 06:30 UTC
Posted Dec 19, 2025 - 15:03 UTC
Scheduled
Horizon Cloud Service First-Gen is undergoing the weekly scheduled maintenance on the Horizon Cloud Console Access.
Maintenance Window:
• Start: Wednesday, December 17, 2025, 03:30 UTC • End: Wednesday, December 17, 2025, 06:30 UTC
Posted Dec 19, 2025 - 15:00 UTC
This scheduled maintenance affects: Console Access (Horizon Cloud Admin Console) (Console Access (Horizon Cloud Admin Console) – AP Australia East (New South Wales)).